Deskriptive Statistik mit Excel

Deskriptive Statistik mit Excel

Deskriptive Statistik mit Excel. Ja, es ist grundsätzlich möglich, deskriptive Statistik mit Excel zu berechnen. Nein, das ist nicht unbedingt kompliziert, wenn man sich ein wenig mit Excel auskennt. Hier zeige ich dir ein paar einfache Befehle, mit denen du grundlegende statistische Maßzahlen wie das arithmetische Mittel, die Standardabweichung, die Korrelation und auch einen Regressionskoeffizienten b berechnen kannst!

Alles was wir dafür brauchen sind die Excel-Befehlfunktionen „Summe“, „Mittelwert“ und „Wurzel“. Voraussetzung dafür ist außerdem, dass du alle Fälle in einer Datenmappe hast. Ordne dabei von links nach rechts (also entlang der Buchstaben) deine verschiedenen Variablen und von oben nach unten deine verschiedenen Fälle.

Nehmen wir also mal an, du hast in den Zellen A1 bis A10 das Alter von 10 Teilnehmenden deiner Befragung stehen. Dann kannst du das arithmetische Mittel dieser Befragten berechnen, in dem du, z.B. in Zelle A12 schreibst: „=MITTELWERT(A1:A10)“ (ohne die Anführungszeichen). Die Zahl, die dann in A12 steht, ist der Altersdurchschnitt.

Möchtest du nun die Varianz berechnen, musst du, laut Formel, zunächst die Differenz jeder Merkmalsausprägung zum Mittelwert berechnen, diese dann quadrieren und von den Quadraten wiederum den Durchschnitt berechnen. Hierzu gehst du, der Reihe nach, wie folgt vor:

Schreibe in Zelle B1 das diese Funktion: „=A1-$A$12“ (ohne Anführungszeichen) und kopierst diesen Code dann in die Zellen B2 bis B10. Die Dollar-Zeichen sind übrigens dafür gut, dass sich das Bezugsfeld des Mittelwertes nicht ändert. Jetzt hast du also in Spalte B die Differenz aller Merkmalsausprägungen vom Mittelwert stehen. Schreibe jetzt in Zelle C1 den folgenden Code: „=B1*B1“ (ohne Anführungszeichen) und kopiere diesen Code in die Zellen C2 bis C10. Jetzt hast du in Spalte C die Quadrate aller Differenzen stehen. Schreibe jetzt, z.B. in Zelle C12: „=MITTELWERT(C1:C10)“ (Ohne Anführungszeichen). Das ist jetzt die Varianz der Altersverteilung. Und wenn du jetzt noch in Zelle C13 schreibst: „=WURZEL(C12)“, dann ist das die Standardabweichung.

Ziemlich einfach, oder? Lass uns mal noch einen Schritt weiter gehen und Pearsons r sowie den Regressionskoeffizienten b berechnen. Stelle dir dazu vor, du hast in den Zellen E1 bis E10 die Ausprägungen einer weiteren variable stehen, z.B. der Körpergröße in Zentimeter. Berechne jetzt nach dem gleichen verfahren wie eben in Spalte F die Differenz der Merkmalsausprägungen vom Mittelwert und in Spalte G das Quadrat der Differenzen. Anschließend in G12 die Varianz und in G13 die Standardabweichung.

Jetzt ist es der nächste Schritt, die Kovarianz zu berechnen. Schreibe hierzu in Zelle I1: „=B1*F1“ und kopiere diesen Code in I2 bis I10. Schreibe jetzt in I12: „=MITTELWERT(I1:I10)“. herzlichen Glückwunsch, das ist deine Kovarianz. Pearsons r ist nun ja die Kovarianz geteilt durch die Standardabweichung von X mal der Standardabweichung von Y. Schreibe also in Zelle I13: „=I12/(C13*G13)“. Der Wert, der jetzt in der zelle steht, ist Pearsons r! Der Regressionskoeffizient b ist ja die Kovarianz geteilt durch die Varianz von X. Schreibe also in I14: „=I12/C12“. Und das wars schon.

Deskriptive Statistik im Studium – in 5 Schritten zu deiner Topnote!

Deskriptive Statistik ist ein fester Bestandteil vieler Studiengänge, Semester für Semester quälen sich tausende von Studierenden durch die entsprechenden Vorlesungen, Seminare und Module. ich verwende das Wort quälen an dieser Stelle bewusst, denn die deskriptive Statistik ist bei vielen Studenten mit einigen, nicht sehr schmeichelhaften Adjektiven belegt. Das habe ich damals als Student am eigenen Leib erfahren und erlebe es heute als Dozent ebenfalls zu genüge[…]